CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner:
Serious problem on an old perl web program

 



traincity2
New User

Apr 10, 2018, 3:33 PM

Post #1 of 2 (4085 views)
Serious problem on an old perl web program Can't Post

Hi... I run an auction site written in perl. Around a month ago we had to move to a new server. I don't know what version perl was being used on the old server but the script had been written around 2003. The software is called ultimate auction if anyone has heard of it. (Originally there were many bugs that we had to get fixed.)

Our new server has the latest version of perl I believe. It is on unix and after having been run for many years with no problem, now it will not refresh each web page correctly (after changing servers and using the newer version of perl. We now believe that it is a problem with the old script running on a new version of perl. Can anyone help figure this out? This is my business and I am willing to pay someone to help us get this fixed if they think they can.

Thanks,

Charlie


BillKSmith
Veteran

Apr 11, 2018, 3:02 PM

Post #2 of 2 (4060 views)
Re: [traincity2] Serious problem on an old perl web program [In reply to] Can't Post

If your application is written entirely in Perl, it should work with a newer version of perl. However, your new version of perl probably comes with new versions of modules that you use. That could be a problem. It is also possible that your perl code is not compatible with your new server software. In any of these cases, there are probably hints in your server's error log. Let us know what you find.
Good Luck,
Bill

 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives