CGI/Perl Guide | Learning Center | Forums | Advertise | Login
Site Search: in

  Main Index MAIN
INDEX
Search Posts SEARCH
POSTS
Who's Online WHO'S
ONLINE
Log in LOG
IN

Home: Perl Programming Help: Beginner:
images in cgi-bin

 



rooroo
Deleted

Mar 21, 2001, 3:13 PM

Post #1 of 3 (269 views)
images in cgi-bin Can't Post

Hello everyone

I am fairly new to perl and new to this is my first post here!!

I am running apache and I have a script that generates an on-the-fly html page...fine it generally works.

the problem is that when I print the final genarated page (to the browser) the images do not show up - the images are in the cgi-bin with the script and the html page has been brought in from a seperate directory into the script

It seems like a permissions kinda thing......can anyone help please

Thank you



japhy
Enthusiast

Mar 21, 2001, 4:21 PM

Post #2 of 3 (268 views)
Re: images in cgi-bin [In reply to] Can't Post

The problem is that every file in the cgi-bin directory is expected to be a program. Thus, even if the file is foo.jpg, the server will try to execute it. Either move the images out of that directory, or make a program that prints the contents of the image.

Jeff "japhy" Pinyan -- accomplished hacker, teacher, lecturer, and author


rooroo
Deleted

Mar 22, 2001, 3:20 PM

Post #3 of 3 (259 views)
Re: images in cgi-bin [In reply to] Can't Post

cheers japhy - i have now got things working

Many Thanks


 
 


Search for (options) Powered by Gossamer Forum v.1.2.0

Web Applications & Managed Hosting Powered by Gossamer Threads
Visit our Mailing List Archives